16:59:30 <pollo> #startmeeting
16:59:30 <MeetBot> Meeting started Thu Oct 12 16:59:30 2017 UTC.  The chair is pollo. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:30 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:59:54 <pollo> #topic Roll Call
16:59:59 <wouter> o/
17:00:02 <pollo> please say hello if you are here for the meeting!
17:00:25 <pollo> in the meantime, please have a look at the proposed agenda: http://deb.li/8eyj
17:00:32 <wouter> are we having a meeting with just two then? ;-)
17:00:44 <pollo> it's pretty bare, so I think it'll go pretty fast
17:00:56 <tumbleweed> o/ (I'm not really here)
17:01:09 <pollo> I think the main goal of today's meeting was to plan for our next sprint
17:01:52 <olasd> hi
17:02:33 <pollo> ivodd, highvoltage ?
17:02:51 <pollo> both said they were interested by the sprint
17:02:55 <ivodd> hi
17:03:52 <pollo> all right, let's start then
17:03:58 <pollo> #topic Cambridge mini-conf
17:04:24 <pollo> #info if you want to ask for sponsorship for the mini-conf, today is the deadline
17:04:43 <pollo> tumbleweed: i did not see the emails you exchanged with the DPL
17:04:45 <wouter> I had tentatively written myself up on the wiki to maybe possibly go to cambridge,
17:04:52 <wouter> but it looks like I won't be able to go in the end
17:04:57 <tumbleweed> all I said was that I knew nothing about travel sponsorship yet
17:04:59 <wouter> not financially, but for various other practical reasons
17:05:10 <tumbleweed> (and got him to sponsor the airbnb for the sprint duration)
17:05:22 <pollo> tumbleweed: do you want to follow-up with hi about official budget, or shall I?
17:05:55 <pollo> wouter: well you can still sprint remotely if you are free
17:06:00 <tumbleweed> I can if we have numbers
17:06:09 <tumbleweed> I suppose we have to, by the end of the day
17:06:12 <tumbleweed> I'll do it and CC you
17:06:15 <wouter> probably won't, at least not full day, but might be doing a bit of that
17:06:35 <ivodd> wouter: you can watch the stream during the miniconf :)
17:06:36 <pollo> #action tumbleweed to ask the DPL for an official sprint budget
17:06:51 <wouter> it's not guaranteed to be impossible yet, either
17:06:59 <pollo> great, olasd you wanted us to talk about hardware?
17:07:01 <wouter> I'll know when we get closer to the day
17:07:49 <olasd> pollo: I want people to list the hardware they need during the sprint so I can bring it
17:08:22 <pollo> do we still have a couple of those old laptops?
17:08:31 <olasd> we still have all the old laptops
17:08:37 <pollo> it would be useful for testing the ansible setup
17:08:37 <tumbleweed> where all = 4
17:08:40 <wouter> olasd: at least the ones that work :)
17:08:48 <olasd> all the ones I have work :p
17:08:54 <wouter> olasd: maybe bring "whatever's in the big box"?
17:09:03 <tumbleweed> there are many big boxes
17:09:05 <olasd> which big box? we have two of these now
17:09:11 <pollo> if we want to test the cameras, we'll need to borrow at least 1 tower PC
17:09:18 <wouter> I thought we had a big box with cameras and a small box with cameras
17:09:21 <wouter> I meant that big box
17:09:28 <olasd> we also have a big box with the old cameras
17:09:38 <wouter> I don't think we want that one :)
17:09:48 <olasd> pollo: I intended to bring our cube anyway
17:09:52 <olasd> we need to record the miniconf
17:09:55 <pollo> a, great
17:09:59 * tumbleweed is pretty much happy with the miniconf equipment
17:10:08 <ivodd> do we need audio gear
17:10:11 <ivodd> for the miniconf
17:11:01 <olasd> probably, yes
17:11:01 <wouter> what does the venue have?
17:11:07 <wouter> (if anything)
17:11:09 <tumbleweed> usually nothing
17:11:10 <pollo> don't we still have a few working mics?
17:11:12 <tumbleweed> the venue is an atrium
17:11:21 <tumbleweed> (or are we in the training room again?)
17:11:32 <wouter> the venue is a company, I'm sure they might have *some* equipment?
17:11:56 <wouter> but meh, probably better to bring our own stuff if we have it
17:11:57 <pollo> #action pollo to find out what audio equipment the venue has
17:12:04 <pollo> I'll keep you posted on that
17:12:42 <olasd> IIRC, we have a full set of microphones for a room
17:12:50 <olasd> (two headsets, two sticks)
17:13:06 <ivodd> some of them even work
17:13:08 <wouter> I think we also used those last year, so perhaps best to bring them, then
17:13:22 <pollo> ivodd: we tested them last fall. If we kept them it's because they were working
17:13:33 <wouter> or I meant two years ago. Time flies.
17:14:09 <pollo> is it worth bringing 4 cameras instead of just 2 for sprinting during the mini-conf?
17:14:25 <wouter> yeah, I think it is
17:14:25 <pollo> I don't think I'll need them
17:14:38 <wouter> that way we can set up the one room to do recordings, and still experiment in a separate room
17:14:58 * tumbleweed is somewhat skeptical of needing them too (most of the sprinting should be done by then)
17:15:04 <wouter> with actual hardware
17:15:24 <ivodd> if we want to testing multiple setups, we need to borrow desktop PCs from somewhere
17:15:37 <wouter> mm, there is that
17:16:15 <pollo> so do we plan to use the Turbot as the opsis computer?
17:16:29 <ivodd> we should try to get that working, yes
17:16:30 <pollo> and the cube for everything elese?
17:16:36 <ivodd> and use an old laptop if it doesn't
17:16:50 <olasd> we did one of those options last year
17:17:09 <ivodd> the cube is the only machine we have that can take the capture cards
17:18:04 <pollo> so we'll need the cube, the laptops, video kit for 1 room, our audio kit as backup and the turbot?
17:18:07 <wouter> ivodd: yes, but pollo was talking about the opsises
17:18:25 <pollo> did RattusRattus take back the opsis he brought to DC17?
17:18:28 <olasd> yes
17:18:40 <pollo> maybe add a spare opsis then
17:19:06 <olasd> I think I'll bring both because I'm lazy and I don't want to unwrap them
17:19:16 <pollo> do we have SDI cables?
17:19:21 <olasd> yes
17:19:41 <olasd> a short one and a spool
17:19:50 <pollo> well I guess that's it for the HW, anything to add on this before we move to the sprint plan?
17:20:01 <taowa> I'm a bit late because of my schedule. Hello.
17:20:25 <pollo> taowa: 0/
17:20:28 <olasd> please collapse that list onto a wiki page
17:20:39 <pollo> #action pollo to add the HW list to the wiki
17:20:45 <olasd> thanks
17:20:50 <pollo> great, now for the sprint plan
17:21:15 <pollo> I was planning to make my way back into our ansible conf and catch up with what I missed
17:21:23 <pollo> but mainly to work on our documentation
17:21:47 <pollo> I want to leave the conf with detailled docs on what we do on the debian wiki
17:22:02 <pollo> so other can easily reproduce our setup if we ship them a kit
17:22:03 <wouter> were we going to make it easy for non-videoteam people to do video?
17:22:11 <wouter> right, so yes :)
17:22:27 <olasd> I intend to make the streaming setup work for ARM (i.e. making sure we can setup the streaming network "head" on a remote server, as we'll only be able to push from the venue)
17:22:29 <pollo> I don't think we'll have enough people to work on the training video this fall
17:23:21 <pollo> #info pollo to work on documentation and our ansible setup
17:23:23 <olasd> also, add scripting for the mirror part
17:23:27 <wouter> would it make sense to have a streaming head in debian.org infrastructure?
17:23:31 <pollo> #info olasd to work on our streaming setup
17:23:34 <tumbleweed> I intend to clean up a lot of ansible
17:23:38 <olasd> wouter: maybe
17:23:52 <pollo> #info tumbleweed to work on our ansible setup
17:24:02 * tumbleweed also has to fall offline in 5 mins
17:24:05 <olasd> I need to talk to DSA beforehand so we can make an informed decision and do work during the sprint
17:24:08 <pollo> ivodd: ?
17:24:11 <ivodd> I want to make it easier to start creating a setup from nothing
17:24:14 <wouter> olasd: makes sense
17:24:23 <ivodd> so installing the first machine and using that to deploy the rest
17:24:28 <olasd> as the streaming uses nginx it's outside of DSA comfort zone :p
17:24:33 <ivodd> which also means cleanups in ansible
17:24:35 <pollo> #info ivodd to work on making the install setup easier
17:24:46 <wouter> they're usually happy to give you a VM if you need it
17:24:53 <wouter> they might just complain about bandwidth though
17:24:54 <olasd> yes, but not root
17:25:02 <wouter> point
17:25:23 <pollo> I think that covers the sprint plan
17:25:31 <pollo> #action pollo to add our sprint plan to the wiki
17:25:40 <pollo> anything else?
17:26:02 <pollo> #topic Next Meeting
17:26:05 <wouter> hang on
17:26:11 <wouter> would it make sense to look into SDI tally lights?
17:26:13 <pollo> Do we need one before the sprint?
17:26:28 <pollo> wouter: we need the HW for that, but the SW is done
17:26:34 <pollo> or "donish"
17:26:43 <wouter> I noticed during dc17 that now that we don't have USB near every camera anymore, that tally becomes something of an issue
17:27:02 * tumbleweed got some serial over cat6 adapter things
17:27:07 <tumbleweed> (well over anything)
17:27:15 <tumbleweed> so we can hack things that'll work
17:27:22 <wouter> but SDI tally is slightly more expensive than a USB serial convertor and a handful of soldered parts
17:27:25 <tumbleweed> SDI would be nicer, but it probably needs a lot of support everywhere
17:27:31 * tumbleweed -> vanishes
17:28:00 <wouter> yeah, it seems to need a ~€300 controller plus ~€50 tally lights etc
17:28:09 <wouter> possibly the controller can be done in software, but then still
17:28:19 <pollo> I think our USB-Serial setup works well enough
17:28:27 <pollo> we need to pass cables to the cams anyway
17:28:33 <wouter> yes, but those are only SDI cables now
17:28:42 <pollo> we just need to pass 1 more cable
17:28:44 <wouter> during dc17 we didn't have tally lights for all cameras
17:28:49 <wouter> which I think is a problem
17:29:03 <wouter> we don't necessary need to fix it with SDI tally, but I do think we should have a solution for that issue
17:29:23 <wouter> if that's "insanely long USB cable" or something of that sorts, I'm happy with that too
17:29:33 <wouter> actually
17:29:38 <olasd> insanely long serial cable
17:29:40 <wouter> we could just make it "insanely long serial cable" instead
17:29:41 <wouter> right :)
17:29:53 <wouter> serial is actually made to support that, so should be easy
17:29:53 <olasd> you know we did that by the end of DC17, right? :)
17:30:00 <wouter> er, nope? whoops, sorry
17:30:17 <wouter> in that case, ignore everything I said, sorry
17:30:20 <pollo> I was kinda planning to ask RattusRattus to make us some during the sprint
17:30:34 <pollo> anyway, next meeting?
17:30:40 <pollo> do we need one before the sprint?
17:31:00 <wouter> if we want to continue the monthly meeting thing, then yes
17:31:06 <wouter> and I think that's a good idea at any rate
17:31:14 <pollo> I also think it's a good idea
17:31:22 <olasd> yeah
17:31:34 <pollo> does not need to be long and it'll help us fix the last bits we need to
17:31:54 <pollo> so that would mean Nov 09th, same time?
17:32:10 <wouter> wfm
17:32:28 <pollo> note that daylight saving time also means it's going to be 1 hour off
17:32:40 <wouter> yes, that's an hour earlier
17:32:48 <wouter> should stll be fine though
17:33:05 <olasd> an hour earlier is fine by me, might be annoying for people on the west coast
17:33:13 <pollo> hmm, good point
17:33:30 <olasd> but all of those people fell off the meeting :p
17:33:35 <pollo> let's bump it up 1 hour then and do 18:00 to 19:00 UTC
17:34:05 <pollo> #agreed next meeting will be on Thursday November 9th, from 18:00 to 19:00 UTC
17:34:09 <pollo> #topic Misc
17:34:33 <wouter> I've been working on Daniel's junk
17:34:45 <olasd> looks like you had a ton of fun
17:34:50 <wouter> he gave me files with timestamps that are wildly off
17:35:06 <wouter> yeah, I did for a while, but grmbl
17:35:21 <wouter> I can probably get it more or less in sync again, but I think next time I'll just tell him to fix it himself
17:35:28 <wouter> having said that,
17:35:45 <wouter> I think it might be nice to have some guidelines on what people can do if they want to publish videos?
17:35:58 <pollo> wouter: that would be nice
17:36:00 <wouter> so that we can avoid this kind of mess in the future
17:36:00 <olasd> if they want _us_ to publish videos, yeah
17:36:05 <wouter> right, yes
17:36:23 <pollo> it think it'll be a worthwhile addition to our "how to video your stuff" doc
17:36:23 <wouter> (he did audio with a smartphone, for crying out loud)
17:36:35 <olasd> to be fair, "please give us masters with synced audio" doesn't sound like a horrible thing to ask
17:36:43 <wouter> right, exactly
17:37:00 <wouter> and if you're not going to do that, "please make sure your clocks are mildly in sync" is not that weird a request, either
17:37:16 <pollo> anything else to add before we end the meeting?
17:37:39 <wouter> I was not trying to make this an idle thought :)
17:37:57 <wouter> I could probably look into that myself, but ideas and input would be welcome
17:38:13 <olasd> wouter: write a first draft to the wiki, send it to the list for comments?
17:38:20 <wouter> probably works
17:38:29 <wouter> #action wouter to write a draft on video submission guidelines
17:38:59 <pollo> #endmeeting